Jump to content

Photo

auto script problem


  • Please log in to reply
1 reply to this topic

#1 faz10

faz10

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 12 December 2016 - 11:50 PM

I am trying to create a "auto script" to run an ansible playbook in an lxc container after create --> start, but its not working out! Basically i have tried: 
 
pct exec ${vmid} /usr/local/bin/ansible-playbook /etc/ansible/playbooks/run.yml
If i run this command in proxmox shell and specify vmid (102) it executes as expected
 
pct exec 102 /usr/local/bin/ansible-playbook /etc/ansible/playbooks/run.yml
I feel like i'm missing something obvious here..


#2 Mohamed Helmy

Mohamed Helmy

    Administrator

  • Administrators
  • 25 posts

Posted 15 December 2016 - 11:31 PM

Hi, 

Can you show the content of your script, is it only this line ?  do you have below line on top of script, also make sure the file itself is executable, try to execute the file manually and check what happens.

 

#!/bin/bash





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Check your Pings